Tf2 crashes on main menu

Hello, I wanted to play TF2 just now but it seems that everytime I start the game it freezes in the very exact moment when the menu shows up, repeatedly playing the very fist second of the "you have new items" sound for a few seconds, then Win7 tells me the program is not responding.

I've already tried verifying the game files (no errors) and disabling some mods (didn't do anything as well). Please help me, fellas.

Oh noes! You're not a Member!

Want access to cool stuff? As a member you can:

  • Post. Give the submitter your thoughts on this Thread.
  • Say Thanks. Show your appreciation by sending the submitter points.
  • Stamp Posts. Let other posters know what you think of their posts.
  • Rate. Give this Thread a rating out of 10.
  • Flag. Alert moderators and warn members of a problem with this Thread.
  • Vote. Vote the submitter for the Monthly Awards.
  • Subscribe. Get notified when this submitter submits again.

Interested? Register or Login

  • You must be a member

Replies

  • Secksy Medic avatar
    Secksy Medic Offline
    864 points Ranked 4247th
    4 medals 1 rare
    Member Joined 4 years ago
    • Report icon
    2 years ago:

    I've had the same problem!

    Ze Charge iz Vready
  • Ti|Nith avatar
    Ti|Nith Offline
    2,554 points Ranked 1405th
    8 medals 1 rare
    Member Joined 2 years ago
    • Report icon
    2 years ago:

    Posted by Secksy Medic I've had the same problem!

    You "had" the same problem? Did you fix it?

    Is that my blood? avatar
    User Title
    Is that my blood?
  • Uncle dolan avatar
    Uncle dolan Offline
    192 points Ranked 13748th
    Member Joined 2 years ago
    • Report icon
    2 years ago:

    It happened to me a few days ago after this destroyed it. http://tf2.gamebanana.com/guis/23545 It did the same thing to me but i deleted it and now swhen i try to enter a server and a bot server (self made, like when you go to tutorial and stuff) it crashes during resources..

    Turns out im missing a resourses folder because i deleted it and tf2 wont restore it either...

    BANNED
  • DBlake avatar
    DBlake Online @ Team Fortress 2
    1,282 points Ranked 2934th
    5 medals 1 rare
    Member Joined 3 years ago
    • Report icon
    2 years ago:

    Posted by LordCowtopianTNT It happened to me a few days ago after this a facepunch colored menu screen destroyed it. It did the same thing to me but i deleted it and now swhen i try to enter a server and a bot server (self made, like when you go to tutorial and stuff) it crashes during resources..

    Turns out im missing a resourses folder because i deleted it and tf2 wont restore it either...

    You're not supposed to add things directly to the main TF2 folder anymore. You need to use the custom directory for this.

    Defunct Modder
  • Uncle dolan avatar
    Uncle dolan Offline
    192 points Ranked 13748th
    Member Joined 2 years ago
    • Report icon
    2 years ago:

    Posted by DBlake

    Posted by LordCowtopianTNT It happened to me a few days ago after this a facepunch colored menu screen destroyed it. It did the same thing to me but i deleted it and now swhen i try to enter a server and a bot server (self made, like when you go to tutorial and stuff) it crashes during resources..

    Turns out im missing a resourses folder because i deleted it and tf2 wont restore it either...

    You're not supposed to add things directly to the main TF2 folder anymore. You need to use the custom directory for this.

    I do, I put vpks into the custom folder and non vpks into

    "my_custom_folder"

    BANNED
  • Secksy Medic avatar
    Secksy Medic Offline
    864 points Ranked 4247th
    4 medals 1 rare
    Member Joined 4 years ago
    • Report icon
    2 years ago:

    Posted by Ti|Nith

    Posted by Secksy Medic I've had the same problem!

    You "had" the same problem? Did you fix it?

    Well I have no idea I'm waiting for my ticket to be answerd from steam support.

    Ze Charge iz Vready
  • TheNotFriendlySpy avatar
    TheNotFriendlySpy Offline
    442 points Ranked 7427th
    4 medals 1 rare
    Member Joined 2 years ago
    • Report icon
    2 years ago:

    im having the same problem. the last time when this happened, i re-installed my windows and it was fixed, i dont know if theres another way to fix it. if someone knows another way to fix it, plz tell us im breaking my computer on the middle trying to fix this sh*t.

    Bananite
  • You must be a member

Submitter

Ti|Nith avatar
Ti|Nith Offline
2,554 points Ranked 1405th
8 medals 1 rare
Member Joined 2 years ago

Ti|Nith

Category

Stats

Post Count
7
ViewCount
1,674
Date Added
2 years ago
Date Modified
-

Share

Code to use:

More embeddable images

Bookmark and Share

Latest Submissions